Attitude Adjustment 12.09 final released

Ειδήσεις σχετικές με το OpenWrt
Άβαταρ μέλους
Acinonyx
Site Admin
Δημοσιεύσεις: 628
Εγγραφή: Τρί, 07 Οκτ 2008, 21:32

Attitude Adjustment 12.09 final released

Δημοσίευσηαπό Acinonyx » Πέμ, 25 Απρ 2013, 19:55

The OpenWrt Release Team would like to announce the
final Attitude Adjustment Release (12.09).

_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
ATTITUDE ADJUSTMENT (12.09, r36088)
-----------------------------------------------------
* 1/4 oz Vodka Pour all ingredients into mixing
* 1/4 oz Gin tin with ice, strain into glass.
* 1/4 oz Amaretto
* 1/4 oz Triple sec
* 1/4 oz Peach schnapps
* 1/4 oz Sour mix
* 1 splash Cranberry juice
-----------------------------------------------------

The OpenWrt 12.09 "attitude_adjustment" source can be checked out at:
svn://svn.openwrt.org/openwrt/tags/atti ... ent_12.09/

Further information on how to checkout the release source is found at:
https://dev.openwrt.org/wiki/GetSource

Highlights since Backfire 10.03.1:
* Dropped support for legacy Broadcom target (brcm-2.4)
* Switched to Kernel 3.3
* Switched to uClibc 0.9.33.2
* Switched x86 images from ext2 to ext4 filesystem
* Improved parallel building support
* New netifd implementation to replace the old script based network
configuration system
* Switched to shadow passwords
* Support for external overlay filesystems in release images
* Various firewall enhancements
* Wireless driver updates and stability improvements
* Experimential support for 5 and 10 MHz channels in ath5k and ath9k
* Package updates and dependency fixes
* New target support: ramips, bcm2708 (Raspberry Pi) and others
* Support for further router models
* Support for building with eglic instead of uClibc
* Support for 6RD configuration
* Support for bridge firewalling in release images

Known Issues:
* Most open tickets at the time of the final builds
* Lower end devices with only 16 MiB RAM will easily run out of
Memory, for bcm47xx based devices is Backfire with brcm-2.4
recommended

More detailed information available at:
https://dev.openwrt.org/query?status=cl ... ment+12.09

Detailed core changelog at:
https://dev.openwrt.org/log/branches/at ... adjustment

Detailed packages changelog at:
https://dev.openwrt.org/log/branches/packages_12.09

Binaries can be downloaded at:
http://downloads.openwrt.org/attitude_adjustment/12.09/

Yours truly,
The OpenWrt developer team

gklis
Δημοσιεύσεις: 41
Εγγραφή: Τρί, 22 Νοέμ 2011, 21:57
Τοποθεσία: Γέρακας Αττικής
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό gklis » Πέμ, 25 Απρ 2013, 23:39

Άντε καλορίζικο!
Το πέρασα ήδη στο 2ο RS Pro μου και προσπαθώ να παίξω λίγο. Προσπαθώ εδω και λίγες μέρες να βάλω μία κάρτα μου (εχω 3 dnma-92 πάνω) να παίξει σε AP mode αλλά δεν τα καταφέρνω και δεν ξέρω τι δεν κάνω σωστά ...
Σε client έπεξε κανονικά και συνδέθηκε και με τον απέναντι που προσπαθώ να στήσω bb link. Οποιαδήπτε βοήθεια ευπρόσδεκτη.

Άβαταρ μέλους
trendy
Δημοσιεύσεις: 767
Εγγραφή: Κυρ, 10 Ιαν 2010, 18:38
Τοποθεσία: Μπρνο, Τσεχία
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό trendy » Παρ, 26 Απρ 2013, 00:53

Ανέβασε λίγο το wireless config να δούμε μπας και σου έχει ξεφύγει κάτι. Πάντως εμένα το bullet είχε θέμα όταν γινόταν client, αλλά σε access point παίζει κανονικά.

gklis
Δημοσιεύσεις: 41
Εγγραφή: Τρί, 22 Νοέμ 2011, 21:57
Τοποθεσία: Γέρακας Αττικής
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό gklis » Σάβ, 27 Απρ 2013, 00:26

Το wireless config μου είναι το παρακάτω:
config wifi-device 'radio0'
option type 'mac80211'
option macaddr '00:1b:b1:83:8f:b9'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option channel '140'
option txpower '17'
option country 'US'
option distance '2997'

config wifi-device 'radio1'
option type 'mac80211'
option macaddr '30:14:4a:86:b7:55'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '1'
option txpower '17'
option country 'US'
option channel 'auto'

config wifi-device 'radio2'
option type 'mac80211'
option macaddr '00:1b:b1:83:8f:bf'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '132'
option txpower '17'
option country 'US'
option distance '5619'

config wifi-iface
option device 'radio0'
option encryption 'none'
option network 'WiFi0'
option ssid 'awmn-4933-14006'
option mode 'ap'

config wifi-iface
option device 'radio1'
option encryption 'none'
option network 'WiFi1'
option ssid 'Omni'
option mode 'sta'

config wifi-iface
option device 'radio2'
option encryption 'none'
option network 'WiFi2'
option ssid 'awmn-9474-4933'
option mode 'sta'
option bssid '00:0B:6B:DE:95:3D'


Στο radio0 είναι που προσπαθω να στήσω το ap.

Επίσης στο radio1 έχω μία omni στην οποία όταν σκανάρω βρίσκω όλως περιέργως μόνο ένα δίκτυο (το wifi από το adsl router μου που είναι ακριβώς κάτω από τη σκεπή) ενώ θα έπρεπε να βρίσκω πάρα πολλά. Γιατι να συμβαίνει αυτό; Υπόψιάζομαι βέβαια μηπως δεν έχει κουμπωσει καλά η κεραία αλλά και πάλι δεν θα έπρεπε να πιάνει περισσότερα; Η να είναι θέμα ρυθμισεων;

Άβαταρ μέλους
trendy
Δημοσιεύσεις: 767
Εγγραφή: Κυρ, 10 Ιαν 2010, 18:38
Τοποθεσία: Μπρνο, Τσεχία
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό trendy » Σάβ, 27 Απρ 2013, 15:35

Κατ'αρχάς το radio1 είναι disabled. Μετά γύρνα τα κανάλια στην ελληνική μπάντα μήπως παίζουν διαφορές με τις ΗΠΑ και για αυτό δεν πιάνεις τα υπόλοιπα δίκτυα. Επίσης χαμήλωσε λίγο την ισχύ, είναι υπερβολικά τα 17dBm με κεραία κουμπωμένη πάνω τους. Κατά τ'άλλα δε βρίσκω κάτι άλλο λάθος στο αρχείο.

gklis
Δημοσιεύσεις: 41
Εγγραφή: Τρί, 22 Νοέμ 2011, 21:57
Τοποθεσία: Γέρακας Αττικής
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό gklis » Σάβ, 27 Απρ 2013, 16:50

Έκανα enable το radio1, γύρισα τα κανάλια στην ελληνική μπαντα σε όλα τα radio, κατεβασα και την ισχύ στο 10 , έκανα και reboot αλλά δεν είδα καμία διαφορά.

Άβαταρ μέλους
trendy
Δημοσιεύσεις: 767
Εγγραφή: Κυρ, 10 Ιαν 2010, 18:38
Τοποθεσία: Μπρνο, Τσεχία
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό trendy » Σάβ, 27 Απρ 2013, 17:30

Δοκίμασε να αλλάξεις θέση στις κάρτες μήπως αυτή που δεν παίζει σε ap έχει κάποιο πρόβλημα.

gklis
Δημοσιεύσεις: 41
Εγγραφή: Τρί, 22 Νοέμ 2011, 21:57
Τοποθεσία: Γέρακας Αττικής
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό gklis » Σάβ, 27 Απρ 2013, 18:28

Εννοείς να είναι πρόβλημα hardware; Αφού σε client έπαιξε και συνδέθηκε κανονικα. Υπάρχει περιπτωση να παίζει σε client και σε ap να μην παίζει;

Άβαταρ μέλους
trendy
Δημοσιεύσεις: 767
Εγγραφή: Κυρ, 10 Ιαν 2010, 18:38
Τοποθεσία: Μπρνο, Τσεχία
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό trendy » Σάβ, 27 Απρ 2013, 23:24

Υποθέσεις κάνω, δε φαίνεται να υπάρχει άλλο θέμα, εκτός αν έχεις πέσει πάνω σε περίεργο bug.

gklis
Δημοσιεύσεις: 41
Εγγραφή: Τρί, 22 Νοέμ 2011, 21:57
Τοποθεσία: Γέρακας Αττικής
Επικοινωνία:

Re: Attitude Adjustment 12.09 final released

Δημοσίευσηαπό gklis » Κυρ, 28 Απρ 2013, 08:17

Τρέχοντας σε command line network restart και wifi μου βγάζει τα παρακάτω:

root@RSpro_02:~# /etc/init.d/network restart
Configuration file: /var/run/hostapd-phy0.conf
wlan0: IEEE 802.11 Configured channel (140) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-4)
wlan0: Unable to setup interface.
Failed to start hostapd for phy0
Successfully initialized wpa_supplicant
command failed: Device or resource busy (-16)
Successfully initialized wpa_supplicant
root@RSpro_02:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
wlan0: IEEE 802.11 Configured channel (140) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-4)
wlan0: Unable to setup interface.
Failed to start hostapd for phy0
Successfully initialized wpa_supplicant
command failed: Device or resource busy (-16)
Successfully initialized wpa_supplicant
root@RSpro_02:~#

Τι συμπέρασμα βγάζετε;


Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης